advertisement
Question
Posted by: Pumi | 2008/02/05

Re: NO periods Post 1632

Goodmorning

I had m/s on the 01/12/2007 and then I bled for about 4days and stopped,after that I noticed that I had a yellow discharge for about a week which I was told it was normal and there was no smell then started bleeding again,I took 2hpt inwhich was positive and then started bleeding very heavy and had abdominal pain like a period cramp.I ran to the doc she said I had a cyst and that could be the reason I had a positive test.I got medication and then after bleeding for about 3-4wks I stopped.

I hope this helps,you can also read my previous posts.22,27,35 and 38

Please help!!
Thank you
Pumi

Not what you were looking for? Try searching again, or ask your own question
Our expert says:
Expert ImageGynaeDoc

It sounds like there could have been some retained fragments of placenta. If the bleeding has now stopped and you have no symptoms, there is no need to worry.

Best wishes

The information provided does not constitute a diagnosis of your condition. You should consult a medical practitioner or other appropriate health care professional for a physical exmanication, diagnosis and formal advice. Health24 and the expert accept no responsibility or liability for any damage or personal harm you may suffer resulting from making use of this content.

Have your say

Thanks for commenting! Your comment will appear on the site shortly.
Thanks for commenting! Your comment will appear on the site shortly.
advertisement