advertisement
Question
Posted by: RM | 2012/02/24

Missed Period but had Tubal Ligation

I had a tubal ligation in Feb 2011. My periods have been regular up until Dec 2011. From Jan 2012 to date, I did not get my period.
I doubt pregnancy because I don''t feel different. Could it be
endometreosis ? What shoud I do ?

Not what you were looking for? Try searching again, or ask your own question
Our expert says:
Expert ImageGynaeDoc

You missed a period in January which was before your sterilisation, so you could have already been pregnant at the time. Check a pregnancy test. Endomertiosis does not cause missed periods.

Best wishes

The information provided does not constitute a diagnosis of your condition. You should consult a medical practitioner or other appropriate health care professional for a physical exmanication, diagnosis and formal advice. Health24 and the expert accept no responsibility or liability for any damage or personal harm you may suffer resulting from making use of this content.

2
Our users say:
Posted by: T | 2012/03/02

gynaedoc, please re read, 2011 and 2012.

Reply to T
Posted by: gynaedoc | 2012/02/27

You missed a period in January which was before your sterilisation, so you could have already been pregnant at the time. Check a pregnancy test. Endomertiosis does not cause missed periods.

Best wishes

Reply to gynaedoc

Have your say

Thanks for commenting! Your comment will appear on the site shortly.
Thanks for commenting! Your comment will appear on the site shortly.
advertisement