advertisement
Question
Posted by: D | 2010-10-27

Help

My periods started on the 6th Oct I had slight bleeding, the 7th &  8th nothing. And I had sharp pains like on my left and right side under my ribcage, my breasts were heavy and my nipples were sore since the 5th. When having sex I was uncomfortable and it did hurt.

I went to the doc on the 14th did a pregnancy test , it was negative. She did other test and she said I have a bladder infection and gave me 5 days antibiotic and on the 18th I had my normal periods.

On saturday I had sex it was painful. Even today its still feels a bit sore on my vagina (the entrance thats where it hurts)

Is the bladder infection not cleared or whats wrong?

Not what you were looking for? Try searching again, or ask your own question
Our expert says:
Expert ImageGynaeDoc

It is hard to say. I would suggest that you go back to your doctor to check.

Best wishes

The information provided does not constitute a diagnosis of your condition. You should consult a medical practitioner or other appropriate health care professional for a physical exmanication, diagnosis and formal advice. Health24 and the expert accept no responsibility or liability for any damage or personal harm you may suffer resulting from making use of this content.

1
Our users say:
Posted by: gynaedoc | 2010-10-28

It is hard to say. I would suggest that you go back to your doctor to check.

Best wishes

Reply to gynaedoc

Have your say

Thanks for commenting! Your comment will appear on the site shortly.
Thanks for commenting! Your comment will appear on the site shortly.
advertisement